Windows 2012 R2 Remote Desktop Enabled Cannot RDP Connect

Windows 2012 RDP Remote Desktop Enabled but you Cannot Connect

You find that after you enable the Windows 2012 RDP or Remote Desktop Connection features to allow you to remote desktop into your new server, you are still unable to connect to the server.

The Cause

By default on new installs of Windows 2012 R2 the server firewall is enabled for TCP IP on Remote Desktop User Mode In TCP-IP.

The Fix

Enable the rule that permits access through the Windows Firewall.

1. Search for Firewall and open “Windows Firewall and Advanced Security”.

2. Find the rule “Remote Desktop – User Mode TCP-in” and ENABLE Rule

Windows 2012 Remote Desktop Firewall Rule

Posted by InteractiveWebs

This blog is the combined blog work of the InteractiveWebs Dev Team. Together we work on a range of DotNetNuke (DNN) applications, modules, Silverlight, and Microsoft CRM Portal integration products. Our Business is website design and hosting, with a strong focus on DotNetNuke, Microsoft Dynamics CRM, Silverlight and iPhone iPad development.

24 comments

Very helpful, thanks!!!

InteractiveWebs

Welcome!

Thanks its working fine 🙂

You do not need to enable the “Shadow (TCP-In)” or the “User Mode (TCP-In)” rules to make RDP function…

Thanks a lot. I was stuck in this remote access for hours.

InteractiveWebs

Welcome

WoW!This method helped in enabled RDP
Thanks

InteractiveWebs

No problem.

Thank you so much, I have been cracking my head for so long to troubleshoot this issue.

InteractiveWebs

Welcome.

Thanks!

InteractiveWebs

Welcome.

Thank you so much.

InteractiveWebs

You are most welcome.

Thank you so mach.

Excellent, works for me, same network. what I need to do to connect from external network?. Tks.

InteractiveWebs

Welcome.

Hi, i,ve got the same problem here. already the inboud rule for remote desktop user mode is enabled. the server can’t respond to ping request but the file and printer sharing (Echo Request-ICMPv4-in) is enabled also. Even the local server is enable for remote connection. Please help?

InteractiveWebs

All I got sorry.

Hi,

More I read your olutions for this issue .. more I think some of my servers are in real trouble:
situation:
Xenserver 6.5;
all my infra is VM based;
CentOS as a router
server 2012 firewall is On;
Rules on server 2012 are enabled;
Rules in the router is Ok (rules for others machines (Windows7, 2012R2, other 2012) is well working;

I havez other infra based on the same model and no problems and there’s only 2 servers 2012 (DC and Exchange) with this issue ..

Very strange ..and time consuming to find “WHY?” ..

Any helps will bz appréciated 😉

Many thanks in advance

Frédéric

InteractiveWebs

The solution is change to a Mac.

Thanks. Working.

Thanks.Working Fine

InteractiveWebs

Welcome.

Leave a Reply