CRM 4.0 Internet explorer has blocked this site from using an ActiveX control in an unsafe manner.

You may have noticed if you connect to a MS CRM 4.0 server after installing Rollup 7 or later, (including rollup 9), that you get a message:

Internet explorer has blocked this site from using an ActiveX control in an unsafe manner.

The cause of this problem is listed in this MS KB: http://support.microsoft.com/kb/976539

The long and the short of it is a known problem in a situation where you have an established relationship with a CRM server using the Outlook plug in. If you then connect to another CRM server that has had the Rollup 7.0 installed, you will get the error message.

Now the official Microsoft Solution to this problem is this: Note You can safely ignore this message and allow blocked content.

Go Microsoft. Yet another totally inadequate solution to a known problem!

What they should have said was this:

1. In IE click tools / Internet Options

2. Click the Security Tab / Trusted Sites
image

3. Click Sites then Add the url of the CRM site giving the message.

4. Click Close (not ok, or save as you might expect, but close).

5. Click Custom Level
image

6. Select Enable next tot he “Initialize and script ActiveX controls not marked as safe fro scripting.
image

7. OK / OK

If you refresh the browser the nasty annoying message is gone for good. This is a client side solution, and not a particularly good one, but hay; I don’t make this mess, just navigate a path around it!

Digg This