DotNetNuke 6 running in .Net 4.0 Server Error in ‘/’ Application Version=3.5.0.0 Version=4.0.0.0

image

We had a requirement today to run a DotNetNuke Website in .Net 4.0 as some code we are using as part of the Microsoft CRM 2011 SDK require .Net 4.0.

Problem is that with many of the DotNetNuke websites, they have some references that will cause this error when you flip your website worker process to 4.0. in IIS.

image

This will give you an error that looks like this:

 

image

Generates an error:

Server Error in ‘/’ Application.

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.
Compiler Error Message: CS1703: An assembly with the same identity ‘System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ has already been imported. Try removing one of the duplicate references.
Source Error:

[No relevant source lines]

Source File: Line: 0

Show Detailed Compiler Output:

 

Interestingly too the reference to Version=4.0.0.0 initially said Version-3.5.0.0 until the second page refresh on the error.

The Problem

The problem in our case, and it may differ with others, related to an older file for Microsoft Ajax.

There is a file called: System.Web.Extensions.dll

in the \bin    folder.

We renamed this to: System.Web.Extensions.dll.bak

And our problem was fixed.

This is due to an older way that Microsoft handled Ajax vs the new way in .Net 4.0.

 

DotNetNuke Support Services

We do offer DotNetNuke support services and would be happy to assist others with this or other DNN problems that need professional support services with.

http://www.interactivewebs.com/Services/DotNetNukeSupport.aspx

10 thoughts on “DotNetNuke 6 running in .Net 4.0 Server Error in ‘/’ Application Version=3.5.0.0 Version=4.0.0.0

  1. bleh. Been trying to get past this for hours… this did it. Was upgrading from 6.1.5 to 7.06 – go tthis initially, then went from 615 to 620 which worked, then 620-706 was back to the error. Now it is all good.

    Thanks for posting this.

    • Glad to be of assistance.

      This is the suggested upgrade path for people updating DotNetNuke

      From Version To Version
      02.00.04 02.01.02
      02.01.02 03.01.01
      03.01.01 03.02.02
      03.02.02 04.03.07 *
      04.03.07 04.04.01
      04.04.01 04.06.02
      04.06.02 04.09.05
      04.09.05 05.04.04 **
      05.04.04 05.05.00
      05.05.00 05.06.07
      05.06.07 06.01.03
      06.01.03 06.02.07
      06.02.07 07.00.06

      With 4.6.2 DotNetNuke introduced functionality known as xmlmerge which automatically does the web.config merging on your behalf.
      * – Requires .Net Framework version 2.0
      ** – Requires .Net Framework version 3.5 SP1

Leave a Reply

Your email address will not be published. Required fields are marked *