2 thoughts on “Microsoft CRM 4.0 Email Router Service Will Not Start

  1. About this file Microsoft.Crm.Tools.EmailAgent.SystemState.xml in the folder C:\Program Files\Microsoft CRM Email\Service >> It simple just u look in service check if MSCRMEmail running or stop,then u check the size of file Microsoft.Crm.Tools.EmailAgent.SystemState.xml in the folder C:\Program Files\Microsoft CRM Email\Service if 0 kb u must rename the extention ex: Microsoft.Crm.Tools.EmailAgent.SystemState.xml2 then if the service run u must stop it first then run the service again, if already stop u just run the service andsee the size of file Microsoft.Crm.Tools.EmailAgent.SystemState.xml in the folder C:\Program Files\Microsoft CRM Email\Service it will have size notin 0 kb again.. I know this so weird I don’t use this solution… because email in CRM 4.0 is the hearth of the CRM applications it self, CRM 4.0 without email is not good application… it’s just like ordinary develop in house software only use dan reuse data…does anyone help me with other better wise solutions, I have this problem on my production server, if email not work, my email workflow will be stuck and Sales team in my company will kill me :(. I’m already update from 1-9 ( 9 is the latest)….pleaseeeee help me………

    • I have had this on several servers. The solution is that I have found is to uninstall the email connector then reinstall. I know it sucks, but Microsoft have on their support page for this type of problem “take a backup so you can replace the directory when it screws up”. Never mind fixing it, their solution is good backup of a working directory. Go figure!

      Anyway, if we made DotNetNuke Modules that needed a good backup for when they break, we would not be in good shape.

Leave a Reply

Your email address will not be published. Required fields are marked *